We are experiencing payment issues
Incident Report for Dapper
Resolved
This incident has been resolved.
Posted Jul 19, 2023 - 17:47 UTC
Investigating
We are investigating payments issues.
Posted Jul 19, 2023 - 17:05 UTC
This incident affected: Payment (Credit & Debit Cards, Dapper Balance, FLOW, BTC, ETH, BCH, DAI, USDC) and Payout (USDC).