We are experiencing payment issues
Incident Report for Dapper
Resolved
This incident has been resolved.
Posted Feb 02, 2023 - 20:56 UTC
Investigating
We are investigating payments issues.
Posted Feb 02, 2023 - 19:01 UTC
This incident affected: Payment (Credit & Debit Cards, Dapper Balance, FLOW, BTC, ETH, BCH, DAI, USDC) and Payout (USDC).