We are experiencing payment issues
Incident Report for Dapper
Resolved
We are investigating payments issues.
Posted Mar 06, 2023 - 18:55 UTC
Identified
We have identified this issue is isolated to LaLiga Golazos and are actively trying to resolve.
Posted Mar 06, 2023 - 18:44 UTC
Investigating
We are investigating payments issues.
Posted Mar 06, 2023 - 18:02 UTC
This incident affected: Payment (Credit & Debit Cards, Dapper Balance, FLOW, BTC, ETH, BCH, DAI, USDC) and Payout (USDC).