We are experiencing payment issues
Incident Report for Dapper
Resolved
We are investigating payments issues.
Posted Jan 19, 2023 - 19:14 UTC
Investigating
We are investigating payments issues.
Posted Jan 19, 2023 - 18:48 UTC
This incident affected: Payment (Credit & Debit Cards, Dapper Balance, BTC, ETH, BCH, DAI, USDC, FLOW) and Payouts (USDC, Wire Transfer).